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Overview / What is beSOURCE?

Overview
What is beSOURCE?
beSOURCE is a source code inspection tool. Through Its static analysis technology,
beSOURCE automatically detects software security defects in a program but without
executing it. The static analysis tool takes program source files and libraries as input and
then uses pattern matching and path flow analysis technologies to identify defects or
vulnerabilities in source code.

Defects are defined by rules in the tool; a rule violation is reported as a defect (or
vulnerability). The violation report includes code line numbers, descriptions of the rules, and
detailed examples that show how to fix the violations.

Through use of the static analysis tool, maintenance efficiency is increased, costs are
reduced, and business disruptions caused by source code defects are prevented.

beSOURCE provides the following benefits:

l Security improvement - By detecting potential security defects in the early stages of
development, you can prevent system breaches through improved application
security.

l Productivity - Maximize development productivity through automatic analysis
instead of manual code review.

l Cost reduction - Reduce the cost of error-fixing and additional maintenance through
the detection of security defects early in development.

l Compliance - Comply with code regulations and standards for secure code.
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Supported technologies
beSOURCE provides predefined rules that are based on industry standards. The tool detects
security defects based on these predefined rules. The supported programming languages
are:

l Java 1.8
l JavaWeb 1.8 (scan all Java, JS, XML and HTML files)
l PHP 7
l Perl 5
l Python 2.7
l Python 3

- C99
l C++

- C# 6
l VB.NET 10
l ASP.NET: aspx and C# files
l ASP.NET: aspx and VB files
l Objective C 6.3
l Visual Basic 6
l Swift 5

NOTE: Most previous versions of some languages are supported by default.

beSOURCE supports the following secure coding standards (rule sets):

For ASP.NET
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For C#

For C++

For C99

For Java

For Javaweb
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For Objective C

beSOURCE contains rules that reflect the available coding guidance of the above standards.
For its static analysis technology, the tool analyzes source code based on the rules.

NOTE: There are two categories of software defects: quality and security. Security
defects are analyzed according to the secure coding standards, detecting application’s
vulnerabilities. The quality-related rules are based on well-known industry coding
standards and international standards. Your purchased license determines the
supported languages and predefined rules. In beSOURCE, quality-related rules are
represented as Quality Rule, and security rules are represented as Security Rule.

Descriptions of standards are shown below:

Standard description

CERT C secure coding guide

CERT C Programming Language Secure Coding Standard (10 09 200 7). Carnegie Mellon
University Software Engineering Institute’s Computer Emergency Response Team defined
the security related development guidelines.

CWE C secure coding guide

CWE means Common Weakness Enumeration. You can see vulnerabilities for several
languages, see https://cwe.mitre.org

CERT C++ secure coding guide
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CERT C++ Secure Coding Standard (28 01 2010).

CERT Java secure coding guide

CERT Java Secure Coding Standard (08 09 2011).

OWASP Top Ten

The OWASP Top Ten is a list of the 10 most dangerous current Web application security
flaws, along with effective methods of dealing with those flaws. OWASP (Open Web
Application Security Project) is an organization that provides unbiased and practical, cost-
effective information about computer and Internet applications.

Executing beSOURCE Developer
You can run the beSOURCE Developer from a web browser (Internet Explorer, Firefox, Safari
etc.) The procedures are as follows:

1. Verify that the Analysis Server and View Server are running.
2. Open your web browser with system administrator privileges and go to the following

URL:
a. http://View_Server_IP:Admin_Server_Port [default port is 50102] (for example,

http://localhost:50102).
i. View_Server_IP is the IP address of Server Computer where the View

Server is installed.
ii. View_Server_Port is the port number assigned at the time of installation.

3. Enter your User ID and Password, and then select Login.
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IMPORTANT: Only users with sufficient rights provided by the administrator can
access the beSOURCE Developer. After five incorrect password attempts,
beSOURCE Developer will block and disable the user account.

4. After logging in, you will see the icons (hover your pointer each one to display a brief
description).

NOTE: The Admin Console icon only appears for users with administrator
privileges.
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5. Select the beSOURCE Developer icon. It will run automatically.

NOTE: If a user tries to log in from another computer after successfully logging in to the
server, the first connection will automatically expire to prevent duplicate connections of
the same user.

Running beSOURCE Developer
After you download beSOURCE Developer with a web browser, you can launch it with a
shortcut icon on your desktop. To launch beSOURCE Developer with a shortcut icon in your
desktop, follow the below steps.

1. To open beSOURCE Developer, double-click the beSOURCE Developer shortcut icon
on your desktop.
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2. In the Server box, select your server. If you need to add a server select Config and do
the following:

a. Select Add.
b. In the Server, IP Address, and Port boxes, enter the beSOURCE View Server's

information.
c. Select Save or Save & Close.

3. Enter your User ID and Password.
4. Select Log In.
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Menus and Start Page
This section describes the menus and UI layout of thebeSOURCE Developer in the Enterprise
edition. When you open beSOURCE Developer, it displays the main menus, toolbar, and start
page.

Menus
beSOURCE Developer provides the following main menus.

l File - Provides basic sub-menus to create or close a project and open or close
windows.

l View - Provides gives access to sub-menus for accessing additional windows and
functions in beSOURCE Developer.

l Analysis - Allows you to start a full or partial code analysis job or stop an analysis.
l Report - Provides a sub-menus for creating reports.
l Tools - Provides sub-menus for editing rule sets and configuring the tool’s

environment.
l Window - Provides sub-menus to returning to the start page or selecting the next

window or preceding window.
l Help - Provides access to on-line help, the current software version, and trademarks.

File menu
The File menu provides the following sub-menus:
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l Login - Opens a beSOURCE Server login window.
l Logout - Terminates the current user session.
l Re-login - Renews the current user session.
l New Project - Opens a wizard to create a new project.
l Open Project - Opens an existing project.
l Close Project - Closes the current, active project.
l Close - Closes the current window.
l Close All - Closes all active windows.
l Export - Provides sub-menus to export the selected window’s data to a file. Notice

that the file exporting might not be supported for the selected window type.
l Print Preview - Opens a preview of the print output.
l Page Setup - Opens the printer setup page you to specify print parameters.
l Print - Initiates the print operation.
l Exit - Terminates beSOURCE Developer.

NOTE: The beSOURCE Enterprise edition also supports a server environment. The
administrator centrally manages base configurations on the beSOURCE server (rule
sets, user accounts, privileges, and so on) and analyzes source files with the server
instance. A developer can download the required data from the server and analyze
source files on a local PC.

View menu
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The View menu provides the following sub-menus:

l Project - Opens a panel with a tree of all source files in the project.
l List of Rule Violations - Opens a window for listing the rule violations in the current

project; it provides multiple information options.
l Rule Description - Opens a window that shows a description of the selected rule,

examples of good and bad code related to the rule, and applicable standards.
l Violation History - Opens a window for showing a history of rule violations.
l Flow Trace - Opens a window for showing control and data flow related to detected

source code lines.
l Category View - Opens a window with rule violations for a selected category.
l Console - Opens a monitoring window for the source code analysis process.
l Summary of Violations - Opens a window displaying the source code that violated

specific rules.

NOTE: beSOURCE Developer supports floating window user interface. You can
personalize the user interface layout. The windows from View menu cannot be placed in
the central document area but can be placed around the central area.

Analysis menu
The Analysis menu provides the following sub-menus:
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l Start Analysis - Initiates analysis of all source files in the current project.
l Start Partial Analysis - Initiates analysis of selected source files or the folder for the

current project.
l Stop Analysis - Stops the current analysis.

Report menu
The Report menu provides the following sub-menus:

l Report for Analysis Results - Generates a total inspection report for the current
active project.

l Analysis Results by Priority - Generates an analysis report for only the selected
priorities.

l Analysis Results by Standard - Generates an inspection report based on the
standard view you selected.

l Source Code Review Report - Generates an Excel file that includes rule violations
and review form.

l Compare History - Shows the differences in the rule violation history of the current
and preceding analysis.

l Analysis Summary - Displays a summary of the source file inspection.
l List of Changed Source Files - Shows a list of changed files in comparison to files in

the preceding analysis.
l Excluded Source Files - Displays a list of files that were excluded from analysis.
l Failed Analysis - Shows the analysis' failed files with error messages.
l Analysis Log - Shows the log for the analysis job itself.
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Tools menu
The Tools menu provides the following sub-menus:

l Options - Opens the Options window, providing access to the environment’s settings.

Options settings

In the Options window, categories are displayed on the left and specific options on the right.

l Environment Configuration > Language - Specifies the default language for the user
interface. You can select English, Japanese, Chinese, or Korean.

l Source Viewer > General - Specifies the font type and size, a default encoding (or
automatic), and the position of the source viewer in the window.

Enterprise Developer Guide www.fortra.com page: 14



Menus and Start Page / Menus

l Font - Specifies the font and character size.
l Encoding - Specifies the default encoding for the source viewer window. Select
Auto to allow the source viewer to automatically select the encoding.

l Source Viewer Position - Specifies a position for the source viewer in the
screen.

l Source Viewer > Rule Violation - Specifies the style and priority of the display of rule
violations.

l Show Style - Specifies a font, font size, font color, and (optional) bold face of
rule names and trace information. This area also lets you select the
background color for rule names.

l Show Priority - Specifies the priorities of the rules to show in the source viewer.
l Project Setting > Basic Setting - Specifies detailed options for source code analysis.

NOTE: The project must exist and be opened before you can specify these basic
settings.
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l Project Name - Describes the name of the project.
l Project Path- The location where the project is saved.
l Language - The project’s programming language type.
l Analysis Mode - LOCAL is for stand-alone analysis on a developer PC. SERVER

is for analysis through server access.
l Ruleset - Allows you to select the rule set for the current project. You can only

use one rule set at a time to analyze a project; this box allows you to select
another rule set for analyzing the project.

l Ruleset Details - Opens a dialog that displays details about the rules. For the
rule you select in the dialog’s left pane, the right pane shows: Rule name, its
priority, a description, examples of good and bad code, and information about
related standards. If the rule has any options, the Option tab displays (if
present): regular expressions, an include or exclude table, and a specific target
type. The popup defaults to the entire set of rules (all standards) for the current
project but also lets you filter by one of the project’s standards (as determined
by your programming language and license). The number of rules in the project
appears in the upper-right corner and varies with filtering (for all standards/all
rules or just for one standard).
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l File Extension - Identifies the file extensions in the project (which is the actual
target of analysis). To add multiple file extensions, use a semicolon (;) as the
delimiter.

l Encoding - Specifies the encoding to use in analyzing a target’s source files.
l CodeMRI Option - An internal option for the analysis engine. Refer to Analysis

Engine Options (CodeMRI Options).
l Maintain Reference File - Specifies whether to reuse reference information

generated by the analysis engine or generate the reference information
whenever an analysis job runs.

l Java Execution Path - Specifies the JDK path used by the internal analysis
engine. You can specify it as an absolute path or a relative path. For the relative
path, you need to specify it in relation to the beSOURCE installation directory.

l Java Execution Option - Specifies JDK execution options that the internal
analysis engine uses.

l Show Message When Opening the Project after Finishing Analysis - Selecting
this option prompts a notification dialog when the project reopens after an
analysis finishes:

l Show Summary after Analysis - Selecting this option prompts the summary
window to open after an analysis finishes.

NOTE:
l The Server Analysis Mode is a unique feature of beSOURCE. If A

project is set on the beSOURCE Server and you want to analyze the
same A project in your local PC with beSOURCE Developer, you can
use this mode. The analysis configuration such as rule set, required
libraries and filter information on the beSOURCE Server will be
automatically synchronized with beSOURCE Developer.

l beSOURCE Server administrator can filter out some false positive rule
violations from the beSOURCE Server’s analysis results. With the
Server Analysis Mode, this filtering information will be automatically
applied to beSOURCE Developer. For example, the administrator
filtered out a SQL injection rule violation in project A, then beSOURCE
Developer automatically filters out the same SQL injection rule
violation in Project A in Local PC.

l Project Setting > Collection Setting -Allows modification of a collection filter.
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l Collection Target - The system that collects or imports source files.
l Edit - Modifies current access information for collecting or importing source files.
l New - Configures a new collection or importing target.
l Importing Path - Specifies the path to import or collect source files.
l Collection Filter - Provides options to add, modify, or delete filters for importing

source files.

NOTE: License Settings displays the applied license. The license determines the
available languages and rule sets. Quality Rule refers to the quality-related rules,
and Security Rule refers to the secure coding-related rules. The license is
applied to the beSOURCE Server.

Window menu
The Window menu provides the following sub-menus:

l Next Window - Activates the next open window in the document area.
l Previous Window - Activates the previous open window in the document area.
l Close All Windows - Closes all windows in the document area.
l Start Page - Opens the Start Page.
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Help menu
The Help menu provides the following sub-menus:

l Help - Opens help information for the active window.
l Table of Contents - Lists the contents of online help as hotlinks
l About -Opens a dialog with beSOURCE version and trademark information.

Toolbar
The following toolbar buttons are available:

l - Opens a print preview window and shows various options for printing the file.

l - Exports the current active information to an Excel or PDF file.

l - When these icons are active and the “Category View” bar is highlighted in

blue, clicking the plus (+) expands the tree of rule names, and clicking the minus (-)
collapses the tree. Note that the tree shows only the rules for the standard shown in
the Relevant Standard box.

l - Starts or stops an analysis in progress.

l - Manually initiates the collecting of changed source files for import.
l - This combination of dropdown list and text box

(to its right) lets you search for instances that match the selected condition in the
dropdown and the text in the box. For example, while ‘Rule Name’ is selected, if you
enter a keyword from a rule name and click the magnifier icon (‘Search Violation’),
you get rule violations corresponding to the condition—if such violations are found.
Alternatively, you can select the name of a standard for the current project in the
dropdown, type a value, and click the magnifier.

l - Opens the Advanced Search Violations window. This window lets you specify

conditions for an advanced search on rule violations.
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l - Opens the Compare Defect History window. Use it to compare rule violations

from one analysis to another between specific dates.
l - Opens a window to upload the results of analysis to the server.

l - Opens the Start Page.

l - Toggles the document area between full screen mode or regular mode.

Start Page
Use Start Page to create a new project or view a summary of an existing project’s
inspection. The functions and their icons are as follows:

l - Launches the wizard for creating a new project.

l Fit to Screen (  ) toggles the width of all the columns such that all columns fit in
the Start Page window or reverts to a subset of columns (which can be viewed by
moving the slide at the bottom of the Start Page window). Also, by closing panes on
the left or right side of the Start Page, you can change the column widths.

l Auto Fit ( ) automatically fits the width of all columns.
l Report ( ) generates a report.
l Delete ( ) removes the selected project(s) or analysis history.

The Start Page also provides a summary of the analysis history. If you click the ( ) icon next
to the project name, Start Page displays all the analysis history for the project.

l Project Name -The name of the project.
l Path - The saved path of the project.
l Language - The programming language type.
l Ruleset - The applied rule set for this project.
l Analysis DateTime - The date and time of the analysis.
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l Elapsed Time - The total time that elapsed for each analysis of the project.
l # of Analysis Target Files - The number of analyzed source files.
l TLOC/SLOC/CLOC - The total lines of code/source lines of code/comment lines of

code.
l Violation Files - The number of source files that have one or more rule violations.
l Violation Count - The number of defects or rule violations found in the selected

analysis of the project.
l New Violation - The number of new rule violations, compared to the preceding

analysis.
l Resolved - The number of resolved rule violations, compared to the preceding

analysis.
l Remaining Violations - The number of identical rule violations, compared to the

preceding analysis.
l Priority - Displays a priority-distribution of rule violations. beSOURCE has five

priorities: critical, recommended-high, recommended-middle, recommended-low, and
information.

Selecting a project name activates the project.

Selecting the number in a specific project’s NEW/Cleared/Same box opens the Compare
Defect History window.

Selecting the time in the project's Analysis Time column activates the project and
inspection results for the date and time displayed. You cannot analyze the project with this
action, but you can view the result.
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Creating and Analyzing a
Project
Creating a project
To create a new project, do the following:

1. On the Start Page, select New Project ( ). The Project Wizard opens.
2. In the Project Name box, enter a name for the project. To transfer the analysis

results to beSOURCE Server, clear the Type the Project Name checkbox and select a
predefined project name on the server.

NOTE: The Enterprise edition of beSOURCE Developer provides additional options
that let you select the project name as it is defined on the server. If the
beSOURCE Server administrator registered the project name, you can select a
project name from a list.

3. In the Language box, select the desired programming language type.
4. In the Project Path, use the default path or select Find and choose a different path.
5. Select Next.

6. Select a one of the following Ruleset options:
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a. Local Ruleset - Applies a rule set to the project during analysis and uses the
rule set inside the tool. The local ruleset is downloaded from the server. Project
analysis can use only one rule set at a time. To select a different rule set for
analyzing the project, select Options > Basic Setting > Ruleset.

b. Server Ruleset - Uses the predefined analysis configuration in the server.
Server-side analysis configurations are displayed if the beSOURCE Server
administrator applied the setting.

7. Select Next.
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8. For Collection Target, select the location of your source files:
a. To import source files from your computer, leave the Collection Target box set

to Local, and then select the location of your files in the Importing Path box.

b. To import your source files by way of FTP, SVN, CVS, GIT, or TFS, select New.
The Connection Settings dialog will open. In the Remote box, select the desired
method, and then refer to the following settings to configure it:
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i. FTP

1. Host - Specifies the FTP server’s IP address.
2. Port - Specifies the port number (default is 21).
3. User - Specifies the user ID to authenticate with the FTP server.
4. Password - Specifies the password that corresponds with the user

ID.
5. Protocol - Specifies the protocol (FTP, SFTP, or FTPS).
6. Timeout(s) - Specifies the number of seconds to wait before timing

out the connection.
7. Encoding - Specifies the encoding for the FTP connection.
8. Passive Mode - FTP uses two channels between the client and

server—the command channel and the data channel (each channel
is a TCP connection). The command channel is for commands and
responses and the data channel is for transferring the files. In
passive mode, the client establishes both channels, and the server
tells the client the port number to use for the data channel.
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ii. SVN

1. URL - Specifies the SVN access address.
2. Port - Specifies the port number (default is 3690).
3. User - Specifies the user ID to authenticate with the SVN server.
4. Password - Specifies the password that corresponds with the user

ID.
5. Encoding - Specifies the encoding for the SVN connection.

iii. CVS
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1. URL - Specifies the CVS server's IP address.
2. Port - Specifies the port number (default is 2401).
3. User - Specifies the user ID to authenticate with the CVS server.
4. Password - Specifies the password that corresponds with the user

ID.
5. Protocol - Specifies the protocol (pserver, ext, extssh, or

pserverssh2).
6. Repository Path - Specifies the path to the source repository.
7. Encoding - Specifies the encoding for the CVS connection.

iv. GIT

1. URL - Specifies the GIT access address.
2. User - Specifies the user ID to authenticate with the GIT server.
3. Password - Specifies the password that corresponds with the user

ID.
4. Encoding - Specifies the encoding for the GIT connection.
5. Use SSH - Enables SSH for the connection (checkbox is cleared by

default). If selected, you must enter the following:
a. SSH-password - Specifies the SSH password.
b. SSH-private-key - Specifies the SSH private key.

v. TFS (Team Foundation Server)
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1. Host - Specifies the Team Foundation Server IP address.
2. User - Specifies the user to authenticate with the GIT server.
1. Password - Specifies the password that corresponds with the user.

9. For Collection Filter, select Add (+) to add a new filter condition as needed.

NOTE:
l You can specify whether the filtering target is included or excluded while

the source files are imported.
l Filter Condition is automatically set according to the selected language, but

you can manually modify it. It displays the analysis target’s file extensions.
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10. Select Next.
11. Review the summary of project settings. You can change options, such as encoding

or the analysis configuration.

12. If the project settings are correct, select Create.
13. Check the results of project creation. To automatically start the analysis after

completing the wizard, select the Open the Project and Start the Analysis checkbox.
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14. Select Finish if the project creation appears complete.

Analyzing a project
You can analyze source files in the active project. To start analyzing a project, take either of
the following two approaches:

l Select Analysis > Start Analysis.
l Select the Start Analysis ( ) icon from the main toolbar.

While the tool is analyzing the project, you can monitor its progress in the lower part of the
Console window.

Error and Warning areas show analysis errors and logs, respectively.
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Selecting the hyperlinks in the Error or Warning tab lets you see the actual source code in
the Source Viewer.

You can see detailed inspection results in the Rule Violations window after the analysis
finishes. You can also see inspection results in the Project window and Category View
window.

If you want to stop an analysis while it is in progress, select Analysis > Stop Analysis or
select the Stop Analysis ( ) icon from the main toolbar.

Analyzing a portion of the source files
You can analyze a portion of the active project by selecting some source files or a folder. To
analyze a portion of the source files, do the following:

1. In the Project window, select a folder or the source files.
2. Select the Analysis > Start Partial Analysis or select the ( ) icon in the main

toolbar. You can check the progress of the analysis in the Console window.

You can see detailed inspection results in the Rule Violations window after finishing an
analysis. The Project window and Category View window also provide the inspection
results.

NOTE: When you analyze a project, the inspection results are automatically saved (to
manage your analysis history). If you want to view the history or remove some of the
history, use the Start Page. To delete an analysis history, select the icon , select an

analysis history, and then select the Delete (   ) icon. ITo change the project's settings,
use the Tools > Options menu.
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Setting the referencing header for C/C++
For a precise analysis of C and C++ projects, all header files referenced by the source files
must be provided. If any portion of the total required header files is missing for any reason,
parsing errors will occur, resulting in an incorrect analysis.

beSOURCE supports a feature for referencing header setting that lets you analyze the
project without parsing errors for the case mentioned above.

To set the referencing header, do the following:

1. Create or open a C or C++ project.
2. Select Tools > Options > Analysis Reference Header Setting. This option has two

categories: builtin and system.
a. builtin - Allows adding header information about missed user defined functions

and types.
b. system - Allows adding header information about system defined functions

and types.

The following tool icons are provided:

l Add Folder ( ) - Adds a sub-folder under the selected item.

l Add Header File ( ) - Adds a header file under the selected item.

l Import Folder ( ) - Imports a folder that contains header files.

Enterprise Developer Guide www.fortra.com page: 32



Creating and Analyzing a Project / Setting the referencing header for C/C++

l Import Header File ( ) - Imports header files.
l Delete ( ) - Deletes the selected header file.

Add missing user-defined header information
To add missing user-defined header information, do the following:

1. Select the builtin category.

2. If necessary, make a sub-category by selecting the Add Folder ( ) icon.

3. Select the Add Header File ( ) icon.
4. Change the name of an added header file within the builtin category.
5. Double-click the new header file and edit its content with additional header

information.
6. Select Save.
7. Check the built-in header file to be included in your project.
8. Select OK.

You can add or edit user-defined declarations or macros in the header file that was added to
the built-in category. The checked header files under the built-in category are expanded with
the analysis target source files by the internal analysis engine.

Adding missing system header information
To add missed system header information, do the following:

1. Select the system category.
2. If necessary, make a sub-category by selecting the Add Folder ( ) icon.

3. Select the Add Header File ( ) icon.

4. Change the name of the added header file in the system category.
5. Double-click the added header file and edit its content.
6. Select Save.
7. Check the system header file to be included in your project.
8. Select OK.

You can add system-related header information to a header file under the system category
(for example, Windows win32 API or a library of UNIX and GCC can be added).
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The checked header files under the system category are expanded with analysis target
source files by internal analysis engine.

If you have predefined header file information, you can import it by using either Import
Folder ( ) or Import Header File ( ) icons.

Analysis engine options (CodeMRI Options)
To specify or change the analysis engine’s options, select Tools > Options > Project Setting
> Basic Setting and then edit the CodeMRI box (see possible values in the figure below.)

The following are the default option values:

l sasp.thread=1 The thread count for parallel processing. A sasp.thread value of 0
means analyzing all targets at once.

l A 1 means analyzing one target at a time after all targets are grouped. A value
of 2 or more specifies parallel analysis after all targets are grouped.

l The thread count should be set to the number of physical CPU cores or
‘physical CPU core count -1’. If the thread count is specified by the number of
logical CPU cores, the consequence is bad performance for a large project.
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l sasp.clear=true - Removes all temporary files and reference information generated
by the last analysis and then analyzes source files. A ‘sasp.clear=false’ setting
reuses temporary files and reference information from the last analysis.

l sasp.indiv - Analyzes source files one at a time. (So function calls through multiple
files are ignored, but function calls within one file are handled during the analysis).

l sasp.info - Provides results in more detailed logs.

To enter multiple option values, separate each with a comma and no space (for example,
sasp.thread=4,sasp.indiv).

NOTE: CodeMRI options are mainly used for security rules or potential runtime error
rules.
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User Interface
Project window
The Project window shows the source files for an active project and lets you analyze some
of them.

To open the Project window, select View > Project.

This panel shows directory structures and source files the project wizard has imported. It
also shows a red number for the defects or rule violations next to each directory and source
file (with red color).

Double-clicking a source file in the Project window opens the source viewer in the central
document area. It provides the following context menus:

l Start Partial Analysis - Starts analysis for the selected source files or folder only.
l Exclude - Excludes some folder or files in analysis. Optionally, add a comment for
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the exclusion in the dialog.

If you exclude a folder, all the source files in the folder are excluded from the analysis job.
Excluded files are displayed with inactive status and any comments you added are shown in
the tool tip window. You can later include the excluded folder or files. If you do so, any
comment for the excluded file will be initialized.

NOTE: Excluded source files are imported but are not analyzed.

The Project window provides the following function icons:

l Sort by File Name ( ) - Sorts the source files by their name.

l Sort by Defects Count ( ) - Sorts the source files by the number of defects.

l Find ( ) - Performs a simple search.

Category View window
The Category View window shows defects or rule violations by a predefined category.
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To open the Category View window, select View > Category View. It lists inspection rules
with the number of defects in parentheses and red color.

Selecting any category (other than All) from the box in the upper-left corner will display the
rules for that category. Selecting a rule in the list synchronizes information in other
corresponding windows, such as the rule description and rule violation.

Category View provides the following tool icons:

l Sort by Priority ( ) - Sorts rules by their priority.

l Sort by Rule Name ( ) - Sorts rules by their name.

l Sort by Defects Count ( ) - Sorts the rules by the number of violations.

l Sort by Standard Name ( ) - Sorts the rules by their related international standard.

l Find ( ) - Provides a simple search function.

List of Rule Violations window
The List of Rule Violations window shows all defects or rule violations along with detailed
information. Because the List of Rule Violations window is also synchronized with the
Project and Category View window, the corresponding information is automatically
displayed when you select an item in those windows.

To open the List of Rule Violations window, select the View > List of Rule Violations. The
List of Rule Violations window shows information about rule violations or defects by
grouping with priority, rule name, and file name.
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The List of Rule Violations window provides the following tool icons:

l Synchronize ( ) - Synchronizes the List of Rule Violations window (or pad) with
the Project window and Category window.

l Grouping by Priority ( ) - Sorts the violation list by the rule's priority.

l Grouping by Priority ( ) - Sorts the violation list by the rule's priority.

l Grouping by rule name ( ) - Sorts the violation list by the rule's name.

l Grouping by file name ( ) - Sorts the violation list by source file’s name.

l View Excluded Items ( ) - Displays excluded defects or rule violations that were

excluded from the list by your configuration of violation status.
l Show Rule Violations for Analyzed Source Only ( ) - Displays defects or rule

violations for only the source files that were recently analyzed.

If you select a rule name, the description of it appears in the Rule Description window.

If you select a source file name, its flow trace and defect history appear in the Trace Info.
window and Defect History window.

If you double-click a source file name, actual source code appears in the Source Viewer.

NOTE: For more information about setting violation status, refer to Violation Status.

Summary of Violations
The Summary of Violations provides summaries of source code for the inspection rule you
select. This information helps you understand the coding patterns that were detected as
violations of the selected rule.

To open the Violation Source Summary window, do the following:
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1. In the Category View, select a rule that has violations.
2. Select View > Summary of Violations to see the window illustrated below.

Source Viewer
The Source Viewer shows source code with defects or rule violation information.

To open the Source Viewer, take the appropriate action from the following:

l Double-click a source file in the Project window.
l Double-click a source file in the Defect Info. window.

The Source Viewer displays followings:
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l On the left-side, the color-coded flag indicates the detected rule’s priority. This line is
immediately above the detected code line (same priority color as the flag). The
summary shows the rule’s name, line number, and more.

l Selecting a rule name's link opens the Rule Description window.
l If the defect has flow trace information, the line has a ▶Trace Info link. Select the

link to open the Trace Info. window.

NOTE:
l You cannot edit the source code in the Source Viewer window.
l The Source Viewer provides a 'Go to Explorer' context menu. If you select this

menu, the corresponding nodes in Project Explorer will have focus.

Rule Description window
The Rule Description window provides a description, example code, related standards, and
option for the rule you selected.

To open the Rule Description window, select View > Rule Description. The window opens
and displays the following tabs:

l Description - Provides detailed information on a rule selected in the Category View
or Defect Info window.

l Example - Provides good example and bad example source code about a rule
selected in the Category View or Defect Info window.

l Standard - Provides international standard information related to a rule selected in
Category View or Defect Info window. If your PC has Internet connection, you can
open a web page of the standard by clicking hyperlink.

l Option - Provides option of rule selected in Category View or Defect Info window.

Flow Trace window
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The Flow Trace window provides flow trace information on a specific defect or rule
violation. For example, if the tool detects a defect in the source file’s line number 15, Trace
Info. displays source code flows related to that line, allowing you to trace back to other
source code lines that affect the detected rule violation.

To open the Trace Info. window, select View > Flow Trace. If you double-click on a row in
the Trace Info window, the Source Viewer opens and puts the cursor at the corresponding
line.

NOTE: Not every rule can provide flow trace information, but if you select a rule that does
support flow trace, the information appears in the window.

Violation Status
You can manage the status of one or more rule violations (defects), as follows:

1. Select a source file or rule violation in the List of Rule Violations window.
2. Select Modify the Violation Status ( ) to open its dialog.

3. In the Violation Status, select one of the following statuses:
a. Defect - Confirmed as a defect or rule violation.
b. Not Defect - Confirmed as a false alarm or the probability of a false alarm is

high.
c. Ignorable - Confirmed as ignorable defect by user review.
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d. Cleared - Confirmed the defect is resolved.
e. Not Reviewed - Review has not been completed.

If you specify a status for the defect, the List of Rule Violations window shows it.

If you set a defect or rule violation to Not Defect, Ignorable, or Cleared, the default list in List
of Rule Violations window and generated report will exclude it.

Selecting View Excluded Items ( ) icon displays the excluded items by setting a violation
status for them. To revert the status of defects, use the Modify the Violation Status context
menu again. Selecting the View Excluded Items ( ) icon again displays the original
defects list.

NOTE: In Enterprise edition, you can transfer the inspection result to the server. A
manager can review the result and communicate about it with others.

Violation History
The Violation History window displays the history of a specific defect or rule violation
selected from the Defect Info window.

To view a defect or rule violation's history, do the following:

1. Select View > Violation History.
2. In the Defect Info window. select a defect. You can check the history of the same

rule violation based on its time of analysis.

Comparing History
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The beSOURCE tool provides useful functionality for intuitively comparing the current
inspection result and the recent defects history for a project.

NOTE: You must have more than two analysis results for a project to make a comparison.

To compare defect histories, do the following:

1. Open a project.
2. Select Report > Compare History in the main menu or click the Compare Defect

History icon. A window opens that will display the comparison results.
3. Alternatively, select two analysis dates/times.
4. Select the Compare button.

If you double-click an item in the list, the source viewer opens with the corresponding code
line.

Advanced search for Rule Violations
Advanced Search can use one of the following bases when searching for rule violations:

l Rule Priority
l Rule name and related standard
l File path and name
l Defect status and your review comment

To perform an advanced search, do the following:
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1. Open the Advanced Search window by doing one of the following:
a. Open a project. The Advanced Search window automatically opens.
b. Select the ( ) icon in the main toolbar.

2. Specify the search conditions, as illustrated in the figure below.
3. Select Search. The search results appear in the Defect Infoz window.

In the search conditions, you can use a (*) as a wild card. Use a semicolon (;) a for delimiter
between multiple search conditions.
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Reports
Creating reports for inspection results
To generate a report for beSOURCE inspection results:

1. Open a project.
2. Select the Report menu.

3. Select a sub-menu for the specific report type.
4. The report is shown in the central document area.

5. Select the Excel or PDF button in the main toolbar. Alternatively, select File > Export
menu.

6. Specify a name for the report file and save it.
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Report types
The following report types are available by default.

l Report for Analysis Results
l Analysis Result by Priority
l Analysis Result by Standard
l Source Code Review Report
l Compare Histories
l Analysis Summary
l List of Changed Source Files
l Excluded Source Files
l Failed Analysis Files
l Analysis Log

Reporting Analysis Results
The Analysis Result Report includes following datasets:

l Summary - Displays information about the number of source files within a project,
LOC, the number of files with defects, total defect count, and defect count by priority.

l Defect files - Displays a list of source files that have rule violations or defects.
l Inspection result by rule - Displays a list of detected rule and defect counts for the

rules.
l Details - Displays rule description, sample code, and code snippet of actual defects
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for each rule.

To create a report with a subset of the rule priorities, select Report > Analysis Result Report
(by Priority) and turn off any of the priorities (Critical, Rec-High, Rec-Middle, Rec-Low, and
Info.).

To select the international standard that the report will reflect, select the Report > Analysis
Result Report (by Standard) menu. The window that pops up is illustrated below:
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Source Code Review Report
The Source Code Review Report lets you download an Excel file that includes a list of rule
violations.

Compare Histories
Refer to the Help topic Comparing Recent Defect History.

Analysis Summary
The Analysis Summary automatically opens after the tool finishes analyzing the source
files.
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The Analysis Summary provides information on analysis configuration, source file changes
compared to preceding analysis, inspection results, and detected rule violations.

l Changed Source Files - Provides information on changed (added, deleted, and
modified) source files counts in the project. The tool automatically imports the
changed source files when you restart a project analysis. If you select a chart, you
can move it to the Source File Changes List window.

l Result of Source File Analysis - Provides the number of excluded, failed, success,
and defect files. If you select the excluded and the failed files chart, you can move to
the Excluded Files List to the Failed Files List window.

l Changes in Violations - Provides the number of new, cleared, and remaining defects,
comparing with the last analysis result.

l Violation Count for Each Priority - Provides the number of defects (rule violations)
by priority.

l Violation Trend for Each Priority - Displays trends in the counts for rule violations
(defects) by priority.

l View Log - Opens the Analysis Log window.

List of Changed Source Files
When you analyze a project again, the tool automatically checks file changes in the project
and again imports only the changed files. The report shows a detailed list of added, deleted,
and modified files in the project.

Excluded Source Files
If you exclude files in a project analysis for any reason, the analysis report shows the list of
excluded files and written comments (if comments exist).
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Failed Analysis Files
If the project analysis generates errors for source files, the report shows a list of source
files whose analysis failed and related error messages.

Analysis Log
beSOURCE displays a log of the analysis of your project.
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Quick Start: Analyzing C/C++
Source Files
Overview
This section describes the procedure for analyzing C or C++ source code.

What you need to know
One characteristic of the C and C++ languages is that they are expanding-type languages.
They merge different types of files, such as a .c file or .cpp file into one expanded file and a
.h file, and then try to compile it. The pre-processing macro that merges and expands the
source files is #include. Every time (most) C or C++ compilers meet a #include macro in
source files during the pre-processing phase, they try to merge the original file and target
‘include’ file. Therefore, if any header files (which define the types used in .c or .cpp files)
are missed, parsing errors occur, and the sources files cannot be correctly analyzed.

To analyze C or C++ source files, you must prepare for all the necessary header files.

C sample source files are provided. You can find them in the beSOURCE_Server_
Installation_Folder\Sample\C folder.

C++ sample source files are provided. You can find them in the beSOURCE_Server_
Installation_Folder\Sample\CPP folder.

Copy the sample source files to your PC.

How to analyze C source files
To analyze source files, do the following:

1. On the Start Page, select New Project. The Project Wizard opens.

NOTE: To analyze source files, you must create a new project.

2. On the first page of the wizard, do the following:
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1. In the Project Name box, enter a name for the project.
2. In the Language box, select C99.
3. In the Project Path box, use the default location, or select Find to specify a

location.

3. Select Next.
4. On the Select Ruleset page, select one of the available rule sets.

NOTE: A rule set is a group of rules. The available rule sets are determined by the
license.

5. Select Next.
6. On the Select Analysis Target Source page, do the following:
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a. In the Importing Path box, select the root directory that includes all the .c and
.h files.

b. (Optional) To import source files from FTP, SVN, CVS, GIT, or TFS select New
and specify the corresponding connection information. Then, specify the root
directory that includes all the .c and .h files.

c. Select the Add icon ( ) to insert a collection filter.
i. If the filter type is Include, all files that match a filter condition are

imported. If the filter type is Exclude, all files that match a filter condition
are not imported. The wizard automatically fills out the filter condition
with default values, and you can add or remove some file extensions. For
specifying multiple file extensions, use a semicolon (;) as the delimiter.

7. Select Next.
8. On the Summary of Project Configuration page, examine the default project options

and, if necessary, specify these options:
a. Encoding - You must select the actual encoding value used in the source files.
b. Target File Extension - Adds or removes file extensions. The delimiter for

multiple file extensions is a semicolon (‘;’). If a file extension is not specified in
this option, analysis ignores the file.

c. Java Execution Option - Specifies the JDK option for internal analysis engine.
On a PC that can support it, you can increase JVM memory. Example: –
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Xms256m –Xmx1024m.

9. Select Create.
10. On the Finish creating the project page, select Open the Project and Start the

Analysis, and then select Finish. You can check the analysis progress in the Console
window.

11. You can check the analysis progress in the Console window.

12. The List of Rule Violations window shows the inspection results after the analysis
finishes.
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a. If you select a rule name, you can see the rule's description, examples of good
and bad code, and international standard identifier of the rule in the Rule
Description window.

b. If you double-click a line number in the column number of the defect, the
Source Viewer displays the actual source code.

c. You can also search specific defects or rule violations by using the Advanced
Search for Violations window.

How to analyze C++ source files
The steps for analyzing C++ source files are the same as for analyzing C source files.
However, there are differences in the setting of the language parser and the rule set in the
Project Wizard. For example, you must specify C++ as the language, as the figure below
illustrates. You must also specify a rule set that applies to C++.

For the remaining steps to analyzing C++ source code, use the steps in the preceding
section, How to Analyze C Source Files.

NOTE: If you see parsing errors due to missing header files, refer to Setting Referencing
Header of C/C++.
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Quick Start: Analyzing Java
Source Files
Overview
This section describes how to analyze Java source files.

Preparation
beSOURCE requires all of the Java source files and libraries for accurate Java analysis.
Typically, Java libraries are included in a .jar file. Therefore, you must ensure that all .jar
files that are used by the targeted source files are imported through the Project Wizard.

Java sample source files are provided. You can find them in the beSOURCE_Server_
Installation_Folder\Sample\Java folder.

Copy the source files to your PC.

How to analyze Java source files
To create a new project for analyzing Java the source files and then immediately start
analysis:

1. On the Start Page, select New Project. The Project Wizard opens.
2. On the first page of the wizard, do the following:

1. In the Project Name box, enter a name for the project.
2. In the Language box, select Java.

NOTE: For the Java language, you can select one of two parsers: Java and
Java Web. Java only analyzes java and jar files. Java Web analyzes
multiple language types at once, such as Java, JSP, JS, and XML.

3. In the Project Path box, use the default location, or select Find to specify a
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location.

3. Select Next.
4. On the Select Ruleset page, select one of the available rule sets.

NOTE: A rule set is a group of rules. The available rule sets are determined by your
license.

5. Select Next.
6. On the Select Analysis Target Source page, do the following:

a. In the Importing Path box, select the root directory that includes all the .c and
.h files.

b. (Optional) To import source files from FTP, SVN, CVS, GIT, or TFS select New
and specify the corresponding connection information. Then, specify the root
directory that includes all the .c and .h files.
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c. Select the Add icon ( ) to insert a collection filter.
i. If the filter type is Include, all files that match a filter condition are

imported. If the filter type is Exclude, all files that match a filter condition
are not imported. The wizard automatically fills out the filter condition
with default values, and you can add or remove some file extensions. For
specifying multiple file extensions, use a semicolon (;) as the delimiter.

7. Select Next.
8. On the Summary of Project Configuration page, examine the default project options

and, if necessary, specify these options:
a. Encoding - You must select the actual encoding value used in the source files.
b. Target File Extension - Adds or removes file extensions. The delimiter for

multiple file extensions is a semicolon (‘;’). If a file extension is not specified in
this option, analysis ignores the file.

c. Java Execution Option - Specifies the JDK option for internal analysis engine.
On a PC that can support it, you can increase JVM memory. Example: –
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Xms256m –Xmx1024m.

9. Select Create.
10. On the Finish creating the project page, select Open the Project and Start the

Analysis, and then select Finish. You can check the analysis progress in the Console
window.

11. You can check the analysis progress in the Console window.

12. The List of Rule Violations window shows the inspection results after the analysis
finishes.
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a. If you select a rule name, you can see the rule's description, examples of good
and bad code, and international standard identifier of the rule in the Rule
Description window.

b. If you double-click a line number in the column number of the defect, the
Source Viewer displays the actual source code.

c. You can also search specific defects or rule violations by using the Advanced
Search for Violations window.
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Command-line Interface
The CLI Analyzer is a utility tool to support simple source code analysis from command-line
window or plug-in of editor tools such as Ultra Edit etc. It is recommended to use it for
simple checking of source code on whether it has rule violations rather than for gaining full
inspection information.

Execution environment
Requires Java virtual machine installation. The Java VM must be version 1.6 or higher.

Command format
java -DCLI_HOME=[cli home directory] -Xmx1024m -jar [CLI_
HOME]/lib/com.codeprism.cli.jar [COMMAND...]

java # java execution file

-DCLI_HOME=[cli home directory] -Xmx1024m # Virtual machine option

-jar [CLI_HOME]/lib/com.codeprism.cli.jar # Java program execution option

Execution command
Sets environment variable and memory option for Java VM.

-DCLI_HOME=[cli home directory] # CLI program’s home directory path

-Xmx1024m # memory usage

Virtual machine option
Enters actually executing program and user input commands.

-jar [CLI_HOME]/lib/com.codeprism.cli.jar [COMMAND...] # Input
com.codeprism.cli.jar file of CLI_HOME’s lib directory.

# Refer to below for [COMMAND...] parameters.

Enterprise Developer Guide www.fortra.com page: 62



Command-line Interface / Job options

Job options
Job list available in command line mode

-cmd # run analysis

-stop # stop current analysis job

-update # get and update module and rules from server

Main job options
Detail options list for each job

Run analysis

-prj_path=[project file path] # assigns project file location

-output=[result file path] # sets file location to save inspection or analysis result

-editor=[result open program] # sets to see inspection result in editor (Window only)

Stop analysis

None

Update rule & library

-server=[cm server url] # assigns server URL

Option for each job

Run analysis

java -DCLI_HOME=c:\cli -Xmx512m -jar
c:\cli\\lib\com.codeprism.cli.jar -cmd -prj-
path=c:\workspace\sample\project.prj -
outout=c:\workspace\sample\out.txt -editor=EditPlus

Stop analysis
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java -DCLI_HOME=c:\cli -Xmx512m -jar
c:\cli\\lib\com.codeprism.cli.jar -stop

Update

java -DCLI_HOME=c:\cli -Xmx512m -jar
c:\cli\\lib\com.codeprism.cli.jar -update -
server=192.168.0.100:50102

Creating a project file
You may configure a project before analyzing source code.

You need to create a project file to indicate project location, location of target source files,
programming language, applying rules and other information.

The extension of the project file is .prj and XML format. Its encoding must be UTF-8.

Project file

<?xml version="1.0" encoding="utf-8"?>

<ProjectTemplate xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<!-- Project Location -->

<!-- Input actual project directory path -->

<Path>[PROJECT_PATH]</Path>

<!-- Parser Type -->

<!-- Input parser type for programming language. -->

<LangCode>3112</LangCode>

<LangName>Java</LangName>

<!-- Input encoding type of target source files. -->

<Encoding>euc-kr</Encoding>

<!-- Applying Rule -->

<RuleSetID>3023112</RuleSetID>

<RuleSetName>CWE/SANS Top 25 Ruleset</RuleSetName>

<!-- Engine Option -->

<CodeMRIOptions>sasp.thread=4</CodeMRIOptions>

<!-- Internal Options -->
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<!-- You may not need to modify them. -->

<LogPath>.log</LogPath>

<FilterPath>.filter</FilterPath>

<DataPath>.data</DataPath>

<DataFileName>data.db</DataFileName>

<DataBackup>true</DataBackup>

<SrcPath>src</SrcPath>

<LibPath>lib</LibPath>

<!-- C, C++ Header File Information -->

<BuiltInHeaders>

<Path />

</BuiltInHeaders>

<SystemHeaders>

<Path />

</SystemHeaders>

<!-- Importing Source Files -->

<Collectors>

<!-- Assigns it for each importing source files directory. -->

<!-- Unique ID is required for each collector. ‘Type=2001’ means that it will import source
files from local disk. -->

<Collector id="1" type="2001" path="[source path]">

<Filters>

<!-- You can import specific file types. 1001 = importing. 1002 = Not importing. -->

<Filter code="1001" value="*.java;*.jar" />

</Filters>

</Collector>

<Collector id="2" type="2001" path="[source or library path]">

<Filters>

<Filter code="1001" value="*.jar" />

</Filters>

</Collector>

</Collectors>

</ProjectTemplate>
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